SAP Security Updates

Number: AV18-061
Date: 11 April 2018

Purpose

The purpose of this advisory is to bring attention to a series of security updates that resolve numerous vulnerabilities with various SAP applications.

Assessment

This SAP security advisory outlines numerous patches that resolve vulnerabilities in their products which range from medium to critical.

Products Affected:

- SAP Business Client, Version 6.5
- SAP Business One, Versions 9.2, 9.3
- SAP Visual Composer, Versions 7.00, 7.01, 7.02, 7.30, 7.31
- SAP Business Objects, Versions 4.0, from 4.10, from 4.20, 4.30
- SAP Cloud Platform Connector, Version - 2.0
- SAP Disclosure Management, Version 10.1
- SAP Solution Manager, Versions 7.10, 7.20
- Sybase PowerBuilder, Version 12.6
- SMP, Version 2.3
- Agentry, Version 6.0
- SAP Open Switch, Version 15.1
- SAP Open Server, Versions 15.7, 16.0
- SDK for SAP ASE, Version 16.0
- SYBASE SOFTWARE DEV KIT, Version 15.7
- SYBASE IQ, Version 15.4
- SAP IQ, Version 16.0
- Sybase SQL Anywhere, Versions 12.0.1, 16.0
- SAP SQL Anywhere, Version 17.0
- SAP SQL Anywhere OnDemand, Version 1.0
- SAP ASE, Versions 15.7, 16.0
- SAP Replication Server, Version 15.7
- SYBASE ECDA, Version 15.7
- SAP HANA Smart Data Streaming, Version 1.0
- SAP Complex Assembly Manufacturing, Version 7.2
- SAP Data Services, Version 4.2
- SAP Crystal Reports Server, OEM Edition, Versions 4.0, 4.10, 4.20, 4.30
- SAP Control Center and SAP Cockpit Framework

CVE References:  CVE-2018-2403, CVE-2018-2404, CVE-2018-2405, CVE-2018-2406, CVE-2018-2408, CVE-2018-2409, CVE-2018-2410, CVE-2018-2412, CVE-2018-2413

Please note that SAP credentials are required to access these references on the link provided below.

Suggested Action

CCIRC recommends that system administrators refer to the linked security note where SAP expands on the details of the vulnerabilities of each of the security notes and provides a patch to resolve the issues on each respective product.

References:

Note to Readers

In support of Public Safety's mission to build a safe and resilient Canada, CCIRC's mandate is to help ensure the security and resilience of the vital non-federal government cyber systems that underpin Canada's national security, public safety and economic prosperity. As Canada's computer security incident response team, CCIRC is Canada's national coordination centre for the prevention and mitigation of, preparedness for, response to, and recovery from cyber incidents on non-federal government systems. It does this by providing authoritative advice and support, and coordinating information sharing and incident response.

Please note, CCIRC PGP key has recently been updated.
http://www.publicsafety.gc.ca/cnt/ntnl-scrt/cbr-scrt/_fl/CCIRCPublicPGPKey.txt

For general information, please contact Public Safety Canada's Public Affairs division at:

Telephone: 613-944-4875 or 1-800-830-3118
Fax: 613-998-9589
E-mail: ps.communications-communications.sp@canada.ca

Date modified: