Samba Security Updates

Number: AV17-175
Date: 21 November 2017

Purpose

The purpose of this advisory is to bring attention to the recently released security updates for Samba.

Assessment

Samba has released security patches to address vulnerabilities which could allow a malicious actor to compromise a system/or exploit memory leaks.

Affected Versions:
CVE-2017-14746: All versions of Samba from 4.0.0 and up.
CVE-2017-15275: All versions of Samba from 3.6.0 and up.

Suggested Action

CCIRC recommends that system administrators test and deploy the vendor-released updates to affected applications or workarounds to affected platforms accordingly.

References:

https://www.samba.org/samba/security/CVE-2017-14746.html
https://www.samba.org/samba/security/CVE-2017-15275.html

Note to Readers

In support of Public Safety's mission to build a safe and resilient Canada, CCIRC's mandate is to help ensure the security and resilience of the vital non-federal government cyber systems that underpin Canada's national security, public safety and economic prosperity. As Canada's computer security incident response team, CCIRC is Canada's national coordination centre for the prevention and mitigation of, preparedness for, response to, and recovery from cyber incidents on non-federal government systems. It does this by providing authoritative advice and support, and coordinating information sharing and incident response.

Please note, CCIRC PGP key has recently been updated.
http://www.publicsafety.gc.ca/cnt/ntnl-scrt/cbr-scrt/_fl/CCIRCPublicPGPKey.txt

For general information, please contact Public Safety Canada's Public Affairs division at:

Telephone: 613-944-4875 or 1-800-830-3118
Fax: 613-998-9589
E-mail: ps.communications-communications.sp@canada.ca

Date modified: